今天看啥  ›  专栏  ›  私忆一秒钟

【CodeForces 1251A --- Broken Keyboard 】

私忆一秒钟  · CSDN  ·  · 2019-10-26 12:15

【CodeForces 1251A --- Broken Keyboard 】


Description

Recently Polycarp noticed that some of the buttons of his keyboard are malfunctioning. For simplicity, we assume that Polycarp’s keyboard contains 26 buttons (one for each letter of the Latin alphabet). Each button is either working fine or malfunctioning.

To check which buttons need replacement, Polycarp pressed some buttons in sequence, and a string s appeared on the screen. When Polycarp presses a button with character c, one of the following events happened:

if the button was working correctly, a character c appeared at the end of the string Polycarp was typing;
if the button was malfunctioning, two characters c appeared at the end of the string.
For example, suppose the buttons corresponding to characters a and c are working correctly, and the button corresponding to b is malfunctioning. If Polycarp presses the buttons in the order a, b, a, c, a, b, a, then the string he is typing changes as follows: a → abb → abba → abbac → abbaca → abbacabb → abbacabba.

You are given a string s which appeared on the screen after Polycarp pressed some buttons. Help Polycarp to determine which buttons are working correctly for sure (that is, this string could not appear on the screen if any of these buttons was malfunctioning).

You may assume that the buttons don’t start malfunctioning when Polycarp types the string: each button either works correctly throughout the whole process, or malfunctions throughout the whole process.

Input

The first line contains one integer t (1≤t≤100) — the number of test cases in the input.

Then the test cases follow. Each test case is represented by one line containing a string s consisting of no less than 1 and no more than 500 lowercase Latin letters.

Output

For each test case, print one line containing a string res. The string res should contain all characters which correspond to buttons that work correctly in alphabetical order, without any separators or repetitions. If all buttons may malfunction, res should be empty.

Sample Input

4
a
zzaaz
ccff
cbddbb

Sample Output

a
z

bc

解题思路:

判断连续出现的相同字母个数是否为奇数,如果为奇数说明该字母键没有损坏,并且记录。

AC代码:

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std;
#define SIS std::ios::sync_with_stdio(false)
#define re register
bool flag[200000];

int main()
{
    SIS;
    string s;
    int T;
    cin >> T;
    while(T--)
    {
        memset(flag,false,sizeof(flag));
        cin >> s;
        s+='0';
        int len=s.size(),num=1;
        for(int i=1;i<len;i++)
        {
            if(s[i]==s[i-1])
                num++;
            else
            {
                if(num&1) flag[s[i-1]-'a']=true;
                num=1;
            }
        }
        for(int i=0;i<26;i++)
            if(flag[i]) cout << char(i+'a');
        cout << endl;
    }
    return 0;
}
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39



原文地址:访问原文地址
快照地址: 访问文章快照