今天看啥  ›  专栏  ›  私忆一秒钟

【CodeForces 1257B --- Magic Stick】

私忆一秒钟  · CSDN  ·  · 2019-11-16 16:16

【CodeForces 1257B --- Magic Stick】


Description

Recently Petya walked in the forest and found a magic stick.

Since Petya really likes numbers, the first thing he learned was spells for changing numbers. So far, he knows only two spells that can be applied to a positive integer:

  • If the chosen number a is even, then the spell will turn it into 3a2;
  • If the chosen number a is greater than one, then the spell will turn it into a−1.

Note that if the number is even and greater than one, then Petya can choose which spell to apply.

Petya now has only one number x. He wants to know if his favorite number y can be obtained from x using the spells he knows. The spells can be used any number of times in any order. It is not required to use spells, Petya can leave x as it is.

Input

The first line contains single integer T (1≤T≤104) — the number of test cases. Each test case consists of two lines.

The first line of each test case contains two integers x and y (1≤x,y≤109) — the current number and the number that Petya wants to get.

Output

For the i-th test case print the answer on it — YES if Petya can get the number y from the number x using known spells, and NO otherwise.

You may print every letter in any case you want (so, for example, the strings yEs, yes, Yes and YES will all be recognized as positive answer).

Sample Input

7
2 3
1 1
3 6
6 8
1 2
4 1
31235 6578234

Sample Output

YES
YES
NO
YES
NO
YES
YES

AC代码:

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
typedef long long ll;

int main()
{
    SIS;
    ll T;
    cin >> T;
    while(T--)
    {
        ll a,b;
        cin >> a >> b;
        if(a==3 && a<b || a==2&&b>3 || a==1&&b!=1)
        {
            cout << "NO" << endl;
            continue;
        }
        cout << "YES" << endl;
    }
    return 0;
}
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25



原文地址:访问原文地址
快照地址: 访问文章快照